From 45b17ed7c245691c4fb565036e3055a6469e25ec Mon Sep 17 00:00:00 2001
From: 1024x2
Date: Mon, 6 May 2024 15:17:26 +0100
Subject: Initial commit

---
 sys-apps/pacman/Manifest            |  1 +
 sys-apps/pacman/pacman-6.0.2.ebuild | 78 +++++++++++++++++++++++++++++++++++++
 2 files changed, 79 insertions(+)
 create mode 100644 sys-apps/pacman/Manifest
 create mode 100644 sys-apps/pacman/pacman-6.0.2.ebuild

(limited to 'sys-apps/pacman')

diff --git a/sys-apps/pacman/Manifest b/sys-apps/pacman/Manifest
new file mode 100644
index 0000000..c212942
--- /dev/null
+++ b/sys-apps/pacman/Manifest
@@ -0,0 +1 @@
+DIST pacman-6.0.2.tar.xz 880868 BLAKE2B 648f62307e413cb352ed92e92df1ace510c1fc5e9ddd254baeef071e89cb7dae1786a95d29c5f69e8b03b1a8cfe3cd65671588dc362c8d3b281c092393aad54c SHA512 9d76fb58c3a50e89a4b92b1f9e3bfdecca3f69e05022ea88fbd34f9df540c4fc688ad4f8b27e77eedb791aa682c27037abe65c789c6d9ee393bae5b620c3df13
diff --git a/sys-apps/pacman/pacman-6.0.2.ebuild b/sys-apps/pacman/pacman-6.0.2.ebuild
new file mode 100644
index 0000000..75838da
--- /dev/null
+++ b/sys-apps/pacman/pacman-6.0.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Archlinux's binary package manager"
+HOMEPAGE="https://archlinux.org/pacman/"
+
+if [[ ${PV} == 9999 ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.archlinux.org/pacman/pacman.git"
+else
+	SRC_URI="https://sources.archlinux.org/other/pacman/${P}.tar.xz"
+	KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/13"
+
+IUSE="curl debug doc +gpg test"
+
+RDEPEND="
+	curl? ( net-misc/curl )
+	gpg? ( app-crypt/gpgme:= )
+	dev-libs/openssl:0=
+	app-arch/libarchive
+"
+DEPEND="
+	${RDEPEND}
+	app-text/asciidoc
+	doc? ( app-doc/doxygen )
+	test? (
+		sys-apps/fakeroot
+		sys-apps/fakechroot
+	)
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+	local emesonargs=(
+		--localstatedir=/var
+		-D crypto=openssl
+		-D doc=enabled
+		$(meson_use debug)
+		$(meson_feature curl)
+		$(meson_feature doc doxygen)
+		$(meson_feature gpg gpgme)
+	)
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install
+
+	# avoid creating stuff inside /var/cache/
+	# see bug #633742 for more information
+	rm -r "${D}"/var/cache/pacman
+	rmdir "${D}"/var/cache
+}
+
+pkg_postinst() {
+	einfo ""
+	einfo "The default root dir was set to ${EPREFIX}/var/chroot/archlinux"
+	einfo "to avoid breaking Gentoo systems due to oscitancy."
+	einfo "If you prefer another directory, take a look at"
+	einfo "pacman's parameter -r|--root)."
+	einfo ""
+	einfo "You will need to setup at least one mirror in /etc/pacman.d/mirrorlist."
+	einfo "Please generate it manually according to the Archlinux documentation:"
+	einfo "https://wiki.archlinux.org/index.php/Mirror"
+	einfo ""
+	einfo "The pacman-contrib scripts have been moved out of the main pacman"
+	einfo "package and now have to be installed from app-misc/pacman-contrib."
+	einfo ""
+}
-- 
cgit v1.2.3