From 876bd7ea3c41511f05f34b39256600c68f8a6c56 Mon Sep 17 00:00:00 2001
From: 1024x2
Date: Sat, 14 Sep 2024 22:18:50 +0100
Subject: sys-apps/pacman: bump to 7.0.0

---
 sys-apps/pacman/Manifest            |  1 +
 sys-apps/pacman/pacman-6.0.2.ebuild |  3 ++
 sys-apps/pacman/pacman-7.0.0.ebuild | 85 +++++++++++++++++++++++++++++++++++++
 sys-apps/pacman/pacman-9999.ebuild  | 85 +++++++++++++++++++++++++++++++++++++
 4 files changed, 174 insertions(+)
 create mode 100644 sys-apps/pacman/pacman-7.0.0.ebuild
 create mode 100644 sys-apps/pacman/pacman-9999.ebuild

(limited to 'sys-apps')

diff --git a/sys-apps/pacman/Manifest b/sys-apps/pacman/Manifest
index c212942..9d2fcc2 100644
--- a/sys-apps/pacman/Manifest
+++ b/sys-apps/pacman/Manifest
@@ -1 +1,2 @@
 DIST pacman-6.0.2.tar.xz 880868 BLAKE2B 648f62307e413cb352ed92e92df1ace510c1fc5e9ddd254baeef071e89cb7dae1786a95d29c5f69e8b03b1a8cfe3cd65671588dc362c8d3b281c092393aad54c SHA512 9d76fb58c3a50e89a4b92b1f9e3bfdecca3f69e05022ea88fbd34f9df540c4fc688ad4f8b27e77eedb791aa682c27037abe65c789c6d9ee393bae5b620c3df13
+DIST pacman-7.0.0.tar.gz 1766639 BLAKE2B d49d824a13092246ed08d33571716a7638c48963720f00d7a5a066f992a4c849dbb47f81e697d0e9d4b06c1c3941cb436379928dbdf6299b63d6bcbcd590ae7d SHA512 c26916775e5bccea878da3d77b17b2e2c99b70f5d8dab99929395ec92ff3b145ae8bc996207ebaada3aa0ab87e95904ec6fdf7bbb08c1a1b823af7732049e1bf
diff --git a/sys-apps/pacman/pacman-6.0.2.ebuild b/sys-apps/pacman/pacman-6.0.2.ebuild
index d2c3f25..6b0b984 100644
--- a/sys-apps/pacman/pacman-6.0.2.ebuild
+++ b/sys-apps/pacman/pacman-6.0.2.ebuild
@@ -46,6 +46,9 @@ src_configure() {
 		--localstatedir=/var
 		-D crypto=openssl
 		-D doc=enabled
+		# Help protect user from shooting their Gentoo installation
+		# in its foot.
+		-Droot-dir="${EPREFIX}/var/chroot/archlinux"
 		$(meson_use debug)
 		$(meson_feature curl)
 		$(meson_feature doc doxygen)
diff --git a/sys-apps/pacman/pacman-7.0.0.ebuild b/sys-apps/pacman/pacman-7.0.0.ebuild
new file mode 100644
index 0000000..e89b14c
--- /dev/null
+++ b/sys-apps/pacman/pacman-7.0.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Archlinux's binary package manager"
+HOMEPAGE="https://archlinux.org/pacman/"
+
+if [[ ${PV} == 9999 ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.archlinux.org/pacman/pacman.git"
+else
+	SRC_URI="https://gitlab.archlinux.org/pacman/pacman/-/archive/v${PV}/pacman-v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64"
+	S="${WORKDIR}/pacman-v${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/13"
+
+IUSE="curl debug doc +gpg test"
+
+RDEPEND="
+	curl? ( >=net-misc/curl-7.55.0 )
+	gpg? ( >=app-crypt/gpgme-1.12.0:= )
+	dev-libs/openssl:0=
+	>=app-arch/libarchive-3.0.0
+	>=app-shells/bash-4.4
+"
+DEPEND="
+	${RDEPEND}
+	test? (
+		sys-apps/fakeroot
+		sys-apps/fakechroot
+	)
+"
+BDEPEND="
+	app-text/asciidoc
+	doc? ( app-text/doxygen )
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+	local emesonargs=(
+		--localstatedir=/var
+		-Dcrypto=openssl
+		-Ddoc=enabled
+		# Help protect user from shooting their Gentoo installation
+		# in its foot.
+		-Droot-dir="${EPREFIX}/var/chroot/archlinux"
+		$(meson_use debug)
+		$(meson_feature curl)
+		$(meson_feature doc doxygen)
+		$(meson_feature gpg gpgme)
+	)
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install
+
+	# avoid creating stuff inside /var/cache/
+	# see bug #633742 for more information
+	rm -r "${D}"/var/cache/pacman
+	rmdir "${D}"/var/cache
+}
+
+pkg_postinst() {
+	einfo ""
+	einfo "The default root dir was set to ${EPREFIX}/var/chroot/archlinux"
+	einfo "to avoid breaking Gentoo systems due to oscitancy."
+	einfo "If you prefer another directory, take a look at"
+	einfo "pacman's parameter -r|--root)."
+	einfo ""
+	einfo "You will need to setup at least one mirror in /etc/pacman.d/mirrorlist."
+	einfo "Please generate it manually according to the Archlinux documentation:"
+	einfo "https://wiki.archlinux.org/index.php/Mirror"
+	einfo ""
+	einfo "The pacman-contrib scripts have been moved out of the main pacman"
+	einfo "package and now have to be installed from app-misc/pacman-contrib."
+	einfo ""
+}
diff --git a/sys-apps/pacman/pacman-9999.ebuild b/sys-apps/pacman/pacman-9999.ebuild
new file mode 100644
index 0000000..e89b14c
--- /dev/null
+++ b/sys-apps/pacman/pacman-9999.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Archlinux's binary package manager"
+HOMEPAGE="https://archlinux.org/pacman/"
+
+if [[ ${PV} == 9999 ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.archlinux.org/pacman/pacman.git"
+else
+	SRC_URI="https://gitlab.archlinux.org/pacman/pacman/-/archive/v${PV}/pacman-v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64"
+	S="${WORKDIR}/pacman-v${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/13"
+
+IUSE="curl debug doc +gpg test"
+
+RDEPEND="
+	curl? ( >=net-misc/curl-7.55.0 )
+	gpg? ( >=app-crypt/gpgme-1.12.0:= )
+	dev-libs/openssl:0=
+	>=app-arch/libarchive-3.0.0
+	>=app-shells/bash-4.4
+"
+DEPEND="
+	${RDEPEND}
+	test? (
+		sys-apps/fakeroot
+		sys-apps/fakechroot
+	)
+"
+BDEPEND="
+	app-text/asciidoc
+	doc? ( app-text/doxygen )
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+	local emesonargs=(
+		--localstatedir=/var
+		-Dcrypto=openssl
+		-Ddoc=enabled
+		# Help protect user from shooting their Gentoo installation
+		# in its foot.
+		-Droot-dir="${EPREFIX}/var/chroot/archlinux"
+		$(meson_use debug)
+		$(meson_feature curl)
+		$(meson_feature doc doxygen)
+		$(meson_feature gpg gpgme)
+	)
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install
+
+	# avoid creating stuff inside /var/cache/
+	# see bug #633742 for more information
+	rm -r "${D}"/var/cache/pacman
+	rmdir "${D}"/var/cache
+}
+
+pkg_postinst() {
+	einfo ""
+	einfo "The default root dir was set to ${EPREFIX}/var/chroot/archlinux"
+	einfo "to avoid breaking Gentoo systems due to oscitancy."
+	einfo "If you prefer another directory, take a look at"
+	einfo "pacman's parameter -r|--root)."
+	einfo ""
+	einfo "You will need to setup at least one mirror in /etc/pacman.d/mirrorlist."
+	einfo "Please generate it manually according to the Archlinux documentation:"
+	einfo "https://wiki.archlinux.org/index.php/Mirror"
+	einfo ""
+	einfo "The pacman-contrib scripts have been moved out of the main pacman"
+	einfo "package and now have to be installed from app-misc/pacman-contrib."
+	einfo ""
+}
-- 
cgit v1.2.3