# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

REL="$(ver_cut 1-2)"
SHORTREL="${REL:2}"

DESCRIPTION="Command-line client for the Perforce VCS"
HOMEPAGE="https://www.perforce.com/"
SRC_URI="
	amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4 -> ${P}-amd64 )
	arm64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26aarch64/p4 -> ${P}-arm64 )
"
S="${WORKDIR}"
LICENSE="Perforce"
SLOT="0"
KEYWORDS="-* ~amd64 ~arm64"
IUSE=""
RESTRICT="mirror strip bindist"

src_unpack() {
	cp "${DISTDIR}/${A}" p4 || die
}

src_install() {
	dobin p4
}