aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author1024x22024-09-04 15:28:47 +0100
committer1024x22024-09-04 15:29:04 +0100
commit016c4dd2d3446a04638201d08b8a05b990e8229c (patch)
treeff7e21c527aee07bde37821ecbc8516a69ee3d2c
parentb0dac1768192e70922c061b2b4e75f29b08deab4 (diff)
app-text/lite-xl-plugin-manager: new ebuild
-rw-r--r--app-text/lite-xl-plugin-manager/Manifest1
-rw-r--r--app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild53
-rw-r--r--app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild53
3 files changed, 107 insertions, 0 deletions
diff --git a/app-text/lite-xl-plugin-manager/Manifest b/app-text/lite-xl-plugin-manager/Manifest
new file mode 100644
index 0000000..02977a8
--- /dev/null
+++ b/app-text/lite-xl-plugin-manager/Manifest
@@ -0,0 +1 @@
+DIST lite-xl-plugin-manager-1.2.9.tar.gz 79192 BLAKE2B b191337ad551f003a9448a16dfdb3dcec68ebc1db031fddfca05bead1e2f89fb1157acb3a91e7e783f5af31fbb5209076428ca29b6b0bdbca7bc53d49a402f77 SHA512 df49d1d0fc3108e573f43b6ca593bdf94ef8eb1c55b0e30e5c12369874a75d8d6809059b4d0a6c64bbabc571bac8949b30cf1dbb274398ed18277e3e586991c5
diff --git a/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild b/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild
new file mode 100644
index 0000000..0121c70
--- /dev/null
+++ b/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plugin manager for app-text/lite-xl"
+HOMEPAGE="https://github.com/lite-xl/lite-xl-plugin-manager"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_SUBMODULES=()
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl-plugin-manager.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl-plugin-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib
+ <net-libs/mbedtls-3
+ dev-libs/libgit2
+ dev-libs/libzip
+ dev-lang/lua:5.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # pkgconfig fix
+ sed -i -e "s/dependency('lua')/dependency('lua5.4')/" meson.build
+
+ eapply_user
+}
+
+src_configure() {
+ # disable self-upgrading (won't work when installed system-wide anyway)
+ append-cppflags '-DLPM_DEFAULT_RELEASE=""'
+
+ local emesonargs=(
+ -Dstatic=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/lpm"
+ einstalldocs
+}
diff --git a/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild b/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild
new file mode 100644
index 0000000..0121c70
--- /dev/null
+++ b/app-text/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plugin manager for app-text/lite-xl"
+HOMEPAGE="https://github.com/lite-xl/lite-xl-plugin-manager"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_SUBMODULES=()
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl-plugin-manager.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl-plugin-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib
+ <net-libs/mbedtls-3
+ dev-libs/libgit2
+ dev-libs/libzip
+ dev-lang/lua:5.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # pkgconfig fix
+ sed -i -e "s/dependency('lua')/dependency('lua5.4')/" meson.build
+
+ eapply_user
+}
+
+src_configure() {
+ # disable self-upgrading (won't work when installed system-wide anyway)
+ append-cppflags '-DLPM_DEFAULT_RELEASE=""'
+
+ local emesonargs=(
+ -Dstatic=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/lpm"
+ einstalldocs
+}