aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author1024x22025-03-03 21:06:12 +0000
committer1024x22025-03-03 21:06:12 +0000
commit727202531f61e08eef031b515ac916d854793b75 (patch)
tree1ffaf5b81217bd31efee8ff035432849a69db030
parent34f3122f043928086beccc1ccc12059ce4530e2a (diff)
games-fps/vkQuake: add 1.32.0
-rw-r--r--games-fps/vkQuake/Manifest1
-rw-r--r--games-fps/vkQuake/vkQuake-1.32.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/games-fps/vkQuake/Manifest b/games-fps/vkQuake/Manifest
index 9f4d884..18c1d38 100644
--- a/games-fps/vkQuake/Manifest
+++ b/games-fps/vkQuake/Manifest
@@ -1 +1,2 @@
DIST vkQuake-1.31.3.tar.gz 28655729 BLAKE2B 707d49973217790400460ba9f259f8d7409ea8f1d9c8011473008e5f64db1586db4c12f1e65fcc295194201decbe1e61a113f5351132e051b372b2023328f3d6 SHA512 97109b810272cd3534287a651f0947fb45a9db6cff7afe31200c944e48252237efa75faed142bc115f44123b4c7a694aca14da88c8f21d6eaa9e5b897ff8566c
+DIST vkQuake-1.32.0.tar.gz 28221073 BLAKE2B e19e8cc897b8c68175a1c68cb796a3a339c9b4954ac030d2efd54a68c264a3d5140bb7e6a9cad71922cfc65fcdfa4f4368f7db73c02c1450cdf39403bdc3de9f SHA512 8a9bf84dac6541a37a8ba092ea1ac066812561b855178f63d37ccab95e5169db951a6ffec5b7f58957ba7bb2f14408a369bba8da649473bf1bf962f0c225162f
diff --git a/games-fps/vkQuake/vkQuake-1.32.0.ebuild b/games-fps/vkQuake/vkQuake-1.32.0.ebuild
new file mode 100644
index 0000000..86290ef
--- /dev/null
+++ b/games-fps/vkQuake/vkQuake-1.32.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Vulkan Quake port based on QuakeSpasm"
+HOMEPAGE="https://github.com/Novum/vkQuake"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novum/vkQuake.git"
+else
+ SRC_URI="https://github.com/Novum/vkQuake/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="mp3 mad flac vorbis tremor opus"
+
+RDEPEND="
+ media-libs/libsdl2
+ media-libs/vulkan-loader
+ mp3? (
+ mad? ( media-libs/libmad )
+ !mad? ( media-sound/mpg123 )
+ )
+ flac? ( media-libs/flac )
+ vorbis? (
+ tremor? ( media-libs/tremor )
+ !tremor? ( media-libs/libvorbis )
+ )
+ opus? (
+ media-libs/opus
+ media-libs/opusfile
+ )
+"
+
+# Build-time dependencies that need to be binary compatible with the system
+# being built (CHOST). These include libraries that we link against.
+# The below is valid if the same run-time depends are required to compile.
+DEPEND="
+ ${RDEPEND}
+ dev-util/vulkan-headers
+"
+
+# Build-time dependencies that are executed during the emerge process, and
+# only need to be present in the native build system (CBUILD). Example:
+BDEPEND="
+ dev-util/glslang
+ dev-util/spirv-tools
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dvorbis_lib=$(usex tremor tremor vorbis)
+ -Dmp3_lib=$(usex mad mad libmpg123)
+ $(meson_feature mp3 use_codec_mp3)
+ $(meson_feature flac use_codec_flac)
+ $(meson_feature vorbis use_codec_vorbis)
+ $(meson_feature opus use_codec_opus)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ cd "${BUILD_DIR}" || die
+ dobin vkquake
+}