aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author1024x22025-03-26 22:35:55 +0000
committer1024x22025-03-26 22:35:55 +0000
commitb9719d2f468734de2d18a45e1bb0e046e766fe69 (patch)
tree9a3598e6c9ffeb74099a2f0e196e0e987061ff6e
parentc3068af18689f4acde3a76d8bc2ea085e940dee0 (diff)
app-editors/lite-xl: add 2.1.7
-rw-r--r--app-editors/lite-xl/Manifest1
-rw-r--r--app-editors/lite-xl/lite-xl-2.1.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/lite-xl/Manifest b/app-editors/lite-xl/Manifest
index ac8bbaf..9f52bd3 100644
--- a/app-editors/lite-xl/Manifest
+++ b/app-editors/lite-xl/Manifest
@@ -1 +1,2 @@
DIST lite-xl-2.1.5.tar.gz 586993 BLAKE2B 5b528ed134a0460b6cb1f12b516fe253afacdbdfcc272b2e684fa60a1208a35cacaa15d4ede9a9eb23ecc9897de19f49b75b34d5c0d58264c00e989eb3a48c1a SHA512 4b61060084f8f2c3a0740bd6e9b6a7eed4a5b3b777d28ad94cd8a80ac461a1579059325151b269a46c2fe0a29dc8adc7e66b055d29b7258515a1a0a5b4dfdf80
+DIST lite-xl-2.1.7.tar.gz 3050138 BLAKE2B 49482a93fa7c45ece19af6c64c3b0f1a0974fb2ccbe79666f6d8adbaeac59caa7c15775e241f4169f0be335fadcb021f2f5fe21a3e8606d38d583024beec624d SHA512 0146846e2735651ecaaab4f2340842dd8e576af34778634436df9ffe87d9afd6f2996d429068689138860549225a304ca923220015e70af81e48167773165ef5
diff --git a/app-editors/lite-xl/lite-xl-2.1.7.ebuild b/app-editors/lite-xl/lite-xl-2.1.7.ebuild
new file mode 100644
index 0000000..2616ec3
--- /dev/null
+++ b/app-editors/lite-xl/lite-xl-2.1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}