aboutsummaryrefslogtreecommitdiffstats
path: root/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild
diff options
context:
space:
mode:
author1024x22025-03-26 22:36:02 +0000
committer1024x22025-03-26 22:36:02 +0000
commitcf79a8eb6d6ffb373b8b89917237e72703040a42 (patch)
tree85e7c843c5a9eb877a9a72c57bf431fa76ccaa3e /app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild
parentb9719d2f468734de2d18a45e1bb0e046e766fe69 (diff)
app-editors/lite-xl-plugin-manager: add 1.4.0HEADmain
Diffstat (limited to 'app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild')
-rw-r--r--app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild
new file mode 100644
index 0000000..58991c1
--- /dev/null
+++ b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plugin manager for app-editors/lite-xl"
+HOMEPAGE="https://github.com/lite-xl/lite-xl-plugin-manager"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_SUBMODULES=()
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl-plugin-manager.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl-plugin-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+lite-xl"
+
+RDEPEND="
+ sys-libs/zlib
+ <net-libs/mbedtls-3
+ dev-libs/libgit2
+ dev-libs/libzip
+ dev-lang/lua:5.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # pkgconfig fix
+ sed -i -e "s/dependency('lua')/dependency('lua5.4')/" meson.build
+
+ eapply_user
+}
+
+src_configure() {
+ # disable self-upgrading (won't work when installed system-wide anyway)
+ append-cppflags '-DLPM_DEFAULT_RELEASE=""'
+
+ local emesonargs=(
+ -Dstatic=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/lpm"
+
+ if use lite-xl; then
+ insinto /usr/share/lite-xl
+ doins -r libraries plugins
+ fi
+
+ einstalldocs
+}