aboutsummaryrefslogtreecommitdiffstats
path: root/app-text/lite-xl/lite-xl-2.1.5.ebuild
diff options
context:
space:
mode:
author1024x22024-09-04 15:29:03 +0100
committer1024x22024-09-04 15:29:03 +0100
commitb0dac1768192e70922c061b2b4e75f29b08deab4 (patch)
tree42a7220bdfb3e6caa57ac1fe678c427386d4ae9e /app-text/lite-xl/lite-xl-2.1.5.ebuild
parent7bcf57d76f66dc7cce0a27b2ef9458dce3df9b66 (diff)
app-text/lite-xl: new ebuild
Diffstat (limited to 'app-text/lite-xl/lite-xl-2.1.5.ebuild')
-rw-r--r--app-text/lite-xl/lite-xl-2.1.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/lite-xl/lite-xl-2.1.5.ebuild b/app-text/lite-xl/lite-xl-2.1.5.ebuild
new file mode 100644
index 0000000..b32fa1f
--- /dev/null
+++ b/app-text/lite-xl/lite-xl-2.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video,threads]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}