aboutsummaryrefslogtreecommitdiffstats
path: root/dev-util
diff options
context:
space:
mode:
author1024x22024-11-25 21:58:14 +0000
committer1024x22024-11-25 21:58:14 +0000
commita666f673b7cb396f1245f821aae2ffdd4010b305 (patch)
treebf954c365cc6a3099959271f2a23f7c56e44cf10 /dev-util
parente018096b27d92cea8a7d642442767b201671bc03 (diff)
dev-util/hx: new package, add 9999
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hx/hx-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/hx/hx-9999.ebuild b/dev-util/hx/hx-9999.ebuild
new file mode 100644
index 0000000..6b53c75
--- /dev/null
+++ b/dev-util/hx/hx-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Much faster version of 'hexdump -C'"
+HOMEPAGE="https://shithub.us/sigrid/hx/HEAD/info.html"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://shithub.us/sigrid/hx"
+else
+ EGIT_COMMIT="56c707043ba4521ca83525ec85d58eaa432ab743"
+ SRC_URI="https://shithub.us/git/sigrid/hx/${EGIT_COMMIT}/snap.tar.gz -> ${PN}-${EGIT_COMMIT}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+}