aboutsummaryrefslogtreecommitdiffstats
path: root/dev-vcs/p4v/p4v-2025.1.2731664.ebuild
diff options
context:
space:
mode:
author1024x22025-03-23 02:41:20 +0000
committer1024x22025-03-23 02:41:20 +0000
commit789980189dc9150b0cc87a46b2c073e9c284f206 (patch)
tree18642d67b9cb839d6399c2d773ee5349640c6403 /dev-vcs/p4v/p4v-2025.1.2731664.ebuild
parent40ae95e19d2cfb453e7a6ebd7873243efc12cb9c (diff)
dev-vcs/p4v: add 2025.1.2731664
Diffstat (limited to 'dev-vcs/p4v/p4v-2025.1.2731664.ebuild')
-rw-r--r--dev-vcs/p4v/p4v-2025.1.2731664.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/p4v/p4v-2025.1.2731664.ebuild b/dev-vcs/p4v/p4v-2025.1.2731664.ebuild
new file mode 100644
index 0000000..2203dc7
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2025.1.2731664.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}