aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation/blastem/blastem-9999.ebuild
diff options
context:
space:
mode:
author1024x22024-05-06 15:17:26 +0100
committer1024x22024-05-06 15:17:26 +0100
commit45b17ed7c245691c4fb565036e3055a6469e25ec (patch)
treef4084521481739c4f70fcaf50413546a0b5a0850 /games-emulation/blastem/blastem-9999.ebuild
Initial commit
Diffstat (limited to 'games-emulation/blastem/blastem-9999.ebuild')
-rw-r--r--games-emulation/blastem/blastem-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/blastem/blastem-9999.ebuild b/games-emulation/blastem/blastem-9999.ebuild
new file mode 100644
index 0000000..0b6f12c
--- /dev/null
+++ b/games-emulation/blastem/blastem-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Sega Genesis / Mega Drive emulator"
+HOMEPAGE="https://www.retrodev.com/blastem/"
+
+if [[ ${PV} == 9999 ]]; then
+ EHG_REPO_URI="https://www.retrodev.com/repos/blastem"
+ inherit mercurial
+else
+ SRC_URI="https://www.retrodev.com/repos/blastem/archive/v${PV}.tar.bz2 -> blastem-${PV}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND="
+ sys-libs/zlib
+ media-libs/libsdl2
+ media-libs/glew
+"
+
+src_compile() {
+ emake \
+ HOST_ZLIB=1 \
+ DATA_PATH=/usr/share/blastem \
+ CONFIG_PATH=/usr/share/blastem
+}
+
+src_install() {
+ dobin blastem
+
+ insinto /usr/share/blastem
+ doins -r shaders images default.cfg rom.db gamecontrollerdb.txt systems.cfg
+}