aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation/simple64-video-parallel
diff options
context:
space:
mode:
author1024x22024-05-06 15:17:26 +0100
committer1024x22024-05-06 15:17:26 +0100
commit45b17ed7c245691c4fb565036e3055a6469e25ec (patch)
treef4084521481739c4f70fcaf50413546a0b5a0850 /games-emulation/simple64-video-parallel
Initial commit
Diffstat (limited to 'games-emulation/simple64-video-parallel')
-rw-r--r--games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild b/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild
new file mode 100644
index 0000000..1ecb651
--- /dev/null
+++ b/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, paraLLEl-RDP video plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/parallel-rdp-standalone.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="420e12f677b5d4f6a624442e20594f181e451760"
+ SRC_URI="https://github.com/simple64/parallel-rdp-standalone/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+ dev-util/vulkan-headers
+"
+RDEPEND="
+ ${DEPEND}
+ media-libs/vulkan-loader
+"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-video-parallel.so"
+}