aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dev-libs/ancient/Manifest1
-rw-r--r--dev-libs/ancient/ancient-2.2.0.ebuild31
-rw-r--r--dev-libs/ancient/ancient-9999.ebuild31
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/ancient/Manifest b/dev-libs/ancient/Manifest
new file mode 100644
index 0000000..6a2bbb2
--- /dev/null
+++ b/dev-libs/ancient/Manifest
@@ -0,0 +1 @@
+DIST ancient-2.2.0.tar.gz 119589 BLAKE2B cd68c4790f62ea1dbaf5c52926d4c8479f2a4032ee2f62b12ea1358b4b1974926659e52dba32781ef73a3d0f877a770fe1144cb83193f33502f4e19fe1d5af62 SHA512 5e184799ba6d6d90f067336800c4d9719396ce5216af916e2498d87a55e1339844659bf2108fe5e65c6a49fb0ac7cc9f0ae7a670a3e5f06668e000257c1e713c
diff --git a/dev-libs/ancient/ancient-2.2.0.ebuild b/dev-libs/ancient/ancient-2.2.0.ebuild
new file mode 100644
index 0000000..7e7808d
--- /dev/null
+++ b/dev-libs/ancient/ancient-2.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modern decompressor for old data compression formats"
+HOMEPAGE="https://foo.example.org/"
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/temisu/ancient.git"
+else
+ SRC_URI="https://github.com/temisu/ancient/archive/refs/tags/v2.2.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/2"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
diff --git a/dev-libs/ancient/ancient-9999.ebuild b/dev-libs/ancient/ancient-9999.ebuild
new file mode 100644
index 0000000..7e7808d
--- /dev/null
+++ b/dev-libs/ancient/ancient-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modern decompressor for old data compression formats"
+HOMEPAGE="https://foo.example.org/"
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/temisu/ancient.git"
+else
+ SRC_URI="https://github.com/temisu/ancient/archive/refs/tags/v2.2.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/2"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}