aboutsummaryrefslogtreecommitdiffstats
path: root/app-editors
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/lite-xl-plugin-manager/Manifest1
-rw-r--r--app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild59
-rw-r--r--app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild59
-rw-r--r--app-editors/lite-xl/Manifest1
-rw-r--r--app-editors/lite-xl/lite-xl-2.1.5.ebuild42
-rw-r--r--app-editors/lite-xl/lite-xl-9999.ebuild42
6 files changed, 204 insertions, 0 deletions
diff --git a/app-editors/lite-xl-plugin-manager/Manifest b/app-editors/lite-xl-plugin-manager/Manifest
new file mode 100644
index 0000000..02977a8
--- /dev/null
+++ b/app-editors/lite-xl-plugin-manager/Manifest
@@ -0,0 +1 @@
+DIST lite-xl-plugin-manager-1.2.9.tar.gz 79192 BLAKE2B b191337ad551f003a9448a16dfdb3dcec68ebc1db031fddfca05bead1e2f89fb1157acb3a91e7e783f5af31fbb5209076428ca29b6b0bdbca7bc53d49a402f77 SHA512 df49d1d0fc3108e573f43b6ca593bdf94ef8eb1c55b0e30e5c12369874a75d8d6809059b4d0a6c64bbabc571bac8949b30cf1dbb274398ed18277e3e586991c5
diff --git a/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild
new file mode 100644
index 0000000..58991c1
--- /dev/null
+++ b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-1.2.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plugin manager for app-editors/lite-xl"
+HOMEPAGE="https://github.com/lite-xl/lite-xl-plugin-manager"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_SUBMODULES=()
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl-plugin-manager.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl-plugin-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+lite-xl"
+
+RDEPEND="
+ sys-libs/zlib
+ <net-libs/mbedtls-3
+ dev-libs/libgit2
+ dev-libs/libzip
+ dev-lang/lua:5.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # pkgconfig fix
+ sed -i -e "s/dependency('lua')/dependency('lua5.4')/" meson.build
+
+ eapply_user
+}
+
+src_configure() {
+ # disable self-upgrading (won't work when installed system-wide anyway)
+ append-cppflags '-DLPM_DEFAULT_RELEASE=""'
+
+ local emesonargs=(
+ -Dstatic=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/lpm"
+
+ if use lite-xl; then
+ insinto /usr/share/lite-xl
+ doins -r libraries plugins
+ fi
+
+ einstalldocs
+}
diff --git a/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild
new file mode 100644
index 0000000..58991c1
--- /dev/null
+++ b/app-editors/lite-xl-plugin-manager/lite-xl-plugin-manager-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plugin manager for app-editors/lite-xl"
+HOMEPAGE="https://github.com/lite-xl/lite-xl-plugin-manager"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_SUBMODULES=()
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl-plugin-manager.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl-plugin-manager/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+lite-xl"
+
+RDEPEND="
+ sys-libs/zlib
+ <net-libs/mbedtls-3
+ dev-libs/libgit2
+ dev-libs/libzip
+ dev-lang/lua:5.4
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # pkgconfig fix
+ sed -i -e "s/dependency('lua')/dependency('lua5.4')/" meson.build
+
+ eapply_user
+}
+
+src_configure() {
+ # disable self-upgrading (won't work when installed system-wide anyway)
+ append-cppflags '-DLPM_DEFAULT_RELEASE=""'
+
+ local emesonargs=(
+ -Dstatic=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/lpm"
+
+ if use lite-xl; then
+ insinto /usr/share/lite-xl
+ doins -r libraries plugins
+ fi
+
+ einstalldocs
+}
diff --git a/app-editors/lite-xl/Manifest b/app-editors/lite-xl/Manifest
new file mode 100644
index 0000000..ac8bbaf
--- /dev/null
+++ b/app-editors/lite-xl/Manifest
@@ -0,0 +1 @@
+DIST lite-xl-2.1.5.tar.gz 586993 BLAKE2B 5b528ed134a0460b6cb1f12b516fe253afacdbdfcc272b2e684fa60a1208a35cacaa15d4ede9a9eb23ecc9897de19f49b75b34d5c0d58264c00e989eb3a48c1a SHA512 4b61060084f8f2c3a0740bd6e9b6a7eed4a5b3b777d28ad94cd8a80ac461a1579059325151b269a46c2fe0a29dc8adc7e66b055d29b7258515a1a0a5b4dfdf80
diff --git a/app-editors/lite-xl/lite-xl-2.1.5.ebuild b/app-editors/lite-xl/lite-xl-2.1.5.ebuild
new file mode 100644
index 0000000..b32fa1f
--- /dev/null
+++ b/app-editors/lite-xl/lite-xl-2.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video,threads]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}
diff --git a/app-editors/lite-xl/lite-xl-9999.ebuild b/app-editors/lite-xl/lite-xl-9999.ebuild
new file mode 100644
index 0000000..b32fa1f
--- /dev/null
+++ b/app-editors/lite-xl/lite-xl-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video,threads]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}