aboutsummaryrefslogtreecommitdiffstats
path: root/dev-libs/ancient/ancient-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ancient/ancient-9999.ebuild')
-rw-r--r--dev-libs/ancient/ancient-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/ancient/ancient-9999.ebuild b/dev-libs/ancient/ancient-9999.ebuild
new file mode 100644
index 0000000..7e7808d
--- /dev/null
+++ b/dev-libs/ancient/ancient-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modern decompressor for old data compression formats"
+HOMEPAGE="https://foo.example.org/"
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/temisu/ancient.git"
+else
+ SRC_URI="https://github.com/temisu/ancient/archive/refs/tags/v2.2.0.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/2"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}