aboutsummaryrefslogtreecommitdiffstats
path: root/dev-vcs/p4/p4-2024.1.2625008.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/p4/p4-2024.1.2625008.ebuild')
-rw-r--r--dev-vcs/p4/p4-2024.1.2625008.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/p4/p4-2024.1.2625008.ebuild b/dev-vcs/p4/p4-2024.1.2625008.ebuild
new file mode 100644
index 0000000..57773de
--- /dev/null
+++ b/dev-vcs/p4/p4-2024.1.2625008.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Command-line client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4 -> ${P}-amd64 )
+"
+S="${WORKDIR}"
+LICENSE="Perforce"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" p4 || die
+}
+
+src_install() {
+ dobin p4
+}