aboutsummaryrefslogtreecommitdiffstats
path: root/dev-vcs/p4v
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/p4v')
-rw-r--r--dev-vcs/p4v/Manifest2
-rw-r--r--dev-vcs/p4v/p4v-2024.3.2656785.ebuild32
-rw-r--r--dev-vcs/p4v/p4v-2024.3.2672664.ebuild32
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-vcs/p4v/Manifest b/dev-vcs/p4v/Manifest
index 1117275..24ec08b 100644
--- a/dev-vcs/p4v/Manifest
+++ b/dev-vcs/p4v/Manifest
@@ -1 +1,3 @@
DIST p4v-2024.2.2634463-amd64.tgz 187838817 BLAKE2B 9cfd19dff2cd9b472ebf94713079ac276ec67492aaa6e9b14ff9dbcb23072748e1a3d0217e116b55204a6a243592bcae1fde41e1c61f14f4a8ff397bde69aef2 SHA512 2743504f8207a4724aec192ee8adf202e0f8e86612c11cda3f3d8a443a345bcd422dd77e36b0643862c966a1acea0ea38c9ecf224197476fc4a3c772fb3bac9f
+DIST p4v-2024.3.2656785-amd64.tgz 188026125 BLAKE2B b0693045fd8762c447e07694416350839004b30284708b2fcdb839672a5b927863c8e66fdce3d7d5559d8f0c89954dcbaf6b8771132fd67ad1d2f5ba9f556859 SHA512 201a03760a2b154f34a37cb7056faffd57ff98cd6c380b4d5f12445717cc0f3e4b953fe19a60ff63c0b28762d52a4ced31c073ab9911944563424671fa77081a
+DIST p4v-2024.3.2672664-amd64.tgz 188042937 BLAKE2B 45a25e393dabb97e2eaeaf63d9d22561a878138b57bcfcdfd101cb5113cd6ec7dc914aa1630bc30cc128c6fd0bdcbdbe1a7d57460ed5a88a0a2cc24be82f7dc6 SHA512 2871010322357156e8d86143907add13c86091575b9c7a2c00507e005c2dcbaf68d14a7a471f4a3c4aea924353c1cd9609723ea9bd2b4fd47bb2f34de04f23b3
diff --git a/dev-vcs/p4v/p4v-2024.3.2656785.ebuild b/dev-vcs/p4v/p4v-2024.3.2656785.ebuild
new file mode 100644
index 0000000..19fbe55
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2024.3.2656785.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://www.perforce.com/downloads/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}
diff --git a/dev-vcs/p4v/p4v-2024.3.2672664.ebuild b/dev-vcs/p4v/p4v-2024.3.2672664.ebuild
new file mode 100644
index 0000000..2203dc7
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2024.3.2672664.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}