aboutsummaryrefslogtreecommitdiffstats
path: root/dev-vcs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/p4/Manifest1
-rw-r--r--dev-vcs/p4/p4-2023.2.2578891.ebuild27
-rw-r--r--dev-vcs/p4v/Manifest3
-rw-r--r--dev-vcs/p4v/p4v-2023.2.2467475.ebuild32
-rw-r--r--dev-vcs/p4v/p4v-2023.4.2558838.ebuild32
-rw-r--r--dev-vcs/p4v/p4v-2024.1.2591061.ebuild32
6 files changed, 127 insertions, 0 deletions
diff --git a/dev-vcs/p4/Manifest b/dev-vcs/p4/Manifest
new file mode 100644
index 0000000..b9e71ae
--- /dev/null
+++ b/dev-vcs/p4/Manifest
@@ -0,0 +1 @@
+DIST p4-2023.2.2578891-amd64 10447528 BLAKE2B 159e991d6b8e7b320ee62d2b50a0050660bb471aa44feebcd96b3bd630e44608aa6b77611d2ec268627d796d3d2550c920e43874815bfec4c83cee7967fc07b5 SHA512 181d8469b0e4062ee3797767285524b6947044b76613eb4b1cd41ab56851cb4d4b8dee1381b373d40f41d3e42caf48761731b566edf198bee61fe53947f785ae
diff --git a/dev-vcs/p4/p4-2023.2.2578891.ebuild b/dev-vcs/p4/p4-2023.2.2578891.ebuild
new file mode 100644
index 0000000..57773de
--- /dev/null
+++ b/dev-vcs/p4/p4-2023.2.2578891.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Command-line client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4 -> ${P}-amd64 )
+"
+S="${WORKDIR}"
+LICENSE="Perforce"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" p4 || die
+}
+
+src_install() {
+ dobin p4
+}
diff --git a/dev-vcs/p4v/Manifest b/dev-vcs/p4v/Manifest
new file mode 100644
index 0000000..810c74b
--- /dev/null
+++ b/dev-vcs/p4v/Manifest
@@ -0,0 +1,3 @@
+DIST p4v-2023.2.2467475-amd64.tgz 194594026 BLAKE2B abeccd350a76330dffb5ec95f1cf5bf79784912f63f44fd647dbb2f8f146a4ae523057436adfffc5e4804712292b9a05cb33c9ccfceb9fe1992631edca8fad8d SHA512 c7e0c0fcf87ee49186a6a2e4b308741cb8173add4ddacb369a2edd30c8b93d37dc01a06ab4fc304d1d96b824339e88975d977cce485748ff6d087daa7a0698b3
+DIST p4v-2023.4.2558838-amd64.tgz 186937615 BLAKE2B e1ff9800247bbbb34c20572b68231fcc1e91bc5ed2b3a13c133a64ed0b047c3183f7c7e498a3e22f59f0bbe5338be025a3d8ab088038d6976f11f8670aa62b9c SHA512 cf88d0d7d25a88ce778fbc63bb04b966a95627d68d7946d64b53c26f2899db15a1ea982667773c462bcba7e7bf5b6c142627d34d45c6c6fdcf75f8a141b942bf
+DIST p4v-2024.1.2591061-amd64.tgz 186905372 BLAKE2B 155f089c174e5b02308d2103d29d1b1c9a2b0c30c14d0aa46f71583db2358ff5b2b75be11cc0269b05b721a7d6ccb7e0fa27738e8c7399adc2f8707a1e70ba5e SHA512 f56c64ff9cb641c1c700ea0000c7299998d80e2dc4cca7967815b0277de22de91419971e513197d8c6819af78fc12d0a7c4698632804f8395f7acc38d5b20a19
diff --git a/dev-vcs/p4v/p4v-2023.2.2467475.ebuild b/dev-vcs/p4v/p4v-2023.2.2467475.ebuild
new file mode 100644
index 0000000..2203dc7
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2023.2.2467475.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}
diff --git a/dev-vcs/p4v/p4v-2023.4.2558838.ebuild b/dev-vcs/p4v/p4v-2023.4.2558838.ebuild
new file mode 100644
index 0000000..2203dc7
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2023.4.2558838.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}
diff --git a/dev-vcs/p4v/p4v-2024.1.2591061.ebuild b/dev-vcs/p4v/p4v-2024.1.2591061.ebuild
new file mode 100644
index 0000000..2203dc7
--- /dev/null
+++ b/dev-vcs/p4v/p4v-2024.1.2591061.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REL="$(ver_cut 1-2)"
+SHORTREL="${REL:2}"
+
+DESCRIPTION="Visual client for the Perforce VCS"
+HOMEPAGE="https://www.perforce.com/"
+SRC_URI="
+ amd64? ( https://ftp.perforce.com/pub/perforce/r${SHORTREL}/bin.linux26x86_64/p4v.tgz -> ${P}-amd64.tgz )
+"
+#S="${WORKDIR}/${P}"
+LICENSE="Perforce-P4V"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+RESTRICT="mirror strip bindist"
+
+RDEPEND="dev-vcs/p4"
+DEPEND=""
+
+src_install() {
+ dodir /opt
+ cp -R "${S}" "${D}/opt/p4v" || die "Install failed!"
+
+ dodir /usr/bin
+ for i in p4admin p4merge p4v p4vc; do
+ dosym ../../opt/p4v/bin/"$i" /usr/bin/"$i"
+ done
+}