aboutsummaryrefslogtreecommitdiffstats
path: root/app-editors/lite-xl
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/lite-xl')
-rw-r--r--app-editors/lite-xl/Manifest1
-rw-r--r--app-editors/lite-xl/lite-xl-2.1.5.ebuild42
-rw-r--r--app-editors/lite-xl/lite-xl-9999.ebuild42
3 files changed, 85 insertions, 0 deletions
diff --git a/app-editors/lite-xl/Manifest b/app-editors/lite-xl/Manifest
new file mode 100644
index 0000000..ac8bbaf
--- /dev/null
+++ b/app-editors/lite-xl/Manifest
@@ -0,0 +1 @@
+DIST lite-xl-2.1.5.tar.gz 586993 BLAKE2B 5b528ed134a0460b6cb1f12b516fe253afacdbdfcc272b2e684fa60a1208a35cacaa15d4ede9a9eb23ecc9897de19f49b75b34d5c0d58264c00e989eb3a48c1a SHA512 4b61060084f8f2c3a0740bd6e9b6a7eed4a5b3b777d28ad94cd8a80ac461a1579059325151b269a46c2fe0a29dc8adc7e66b055d29b7258515a1a0a5b4dfdf80
diff --git a/app-editors/lite-xl/lite-xl-2.1.5.ebuild b/app-editors/lite-xl/lite-xl-2.1.5.ebuild
new file mode 100644
index 0000000..b32fa1f
--- /dev/null
+++ b/app-editors/lite-xl/lite-xl-2.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video,threads]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}
diff --git a/app-editors/lite-xl/lite-xl-9999.ebuild b/app-editors/lite-xl/lite-xl-9999.ebuild
new file mode 100644
index 0000000..b32fa1f
--- /dev/null
+++ b/app-editors/lite-xl/lite-xl-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="A extensible text editor written in C, and Lua, adapted from lite"
+HOMEPAGE="https://lite-xl.com/en/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lite-xl/lite-xl.git"
+else
+ SRC_URI="https://github.com/lite-xl/lite-xl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-lang/lua:5.4
+ dev-libs/libpcre2
+ media-libs/freetype:2
+ media-libs/libsdl2[video,threads]
+"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Duse_system_lua=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/lite-xl" "${D}/usr/share/doc/${P}" || die
+}