aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation/blastem
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/blastem')
-rw-r--r--games-emulation/blastem/Manifest1
-rw-r--r--games-emulation/blastem/blastem-0.6.2.ebuild39
-rw-r--r--games-emulation/blastem/blastem-9999.ebuild38
3 files changed, 78 insertions, 0 deletions
diff --git a/games-emulation/blastem/Manifest b/games-emulation/blastem/Manifest
new file mode 100644
index 0000000..6add171
--- /dev/null
+++ b/games-emulation/blastem/Manifest
@@ -0,0 +1 @@
+DIST blastem-0.6.2.tar.bz2 1013238 BLAKE2B 5aa5ae867d5a6fb25fbb116fd698e59b4c2fdc9adffa50571e7449a43ed9ac77bc1fbdb3d1bbf132286ed30d34d41bbaff90905745b37789b483e647d871622c SHA512 fd924e5ec173f309e9e4108b78037ec78ed0f16d98e038a9a79f4e7237e30c1df4c7d65b166f65a26a20051e4c1d4b0c050bebd6f920e5e27ac467cb04e338e4
diff --git a/games-emulation/blastem/blastem-0.6.2.ebuild b/games-emulation/blastem/blastem-0.6.2.ebuild
new file mode 100644
index 0000000..5e4b4b5
--- /dev/null
+++ b/games-emulation/blastem/blastem-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Sega Genesis / Mega Drive emulator"
+HOMEPAGE="https://www.retrodev.com/blastem/"
+
+if [[ ${PV} == 9999 ]]; then
+ EHG_REPO_URI="https://www.retrodev.com/repos/blastem"
+ inherit mercurial
+else
+ SRC_URI="https://www.retrodev.com/repos/blastem/archive/v${PV}.tar.bz2 -> blastem-${PV}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86"
+ S="${WORKDIR}/blastem-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND="
+ sys-libs/zlib
+ media-libs/libsdl2
+ media-libs/glew
+"
+
+src_compile() {
+ emake \
+ HOST_ZLIB=1 \
+ DATA_PATH=/usr/share/blastem \
+ CONFIG_PATH=/usr/share/blastem
+}
+
+src_install() {
+ dobin blastem
+
+ insinto /usr/share/blastem
+ doins -r shaders images default.cfg rom.db gamecontrollerdb.txt systems.cfg
+}
diff --git a/games-emulation/blastem/blastem-9999.ebuild b/games-emulation/blastem/blastem-9999.ebuild
new file mode 100644
index 0000000..0b6f12c
--- /dev/null
+++ b/games-emulation/blastem/blastem-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Sega Genesis / Mega Drive emulator"
+HOMEPAGE="https://www.retrodev.com/blastem/"
+
+if [[ ${PV} == 9999 ]]; then
+ EHG_REPO_URI="https://www.retrodev.com/repos/blastem"
+ inherit mercurial
+else
+ SRC_URI="https://www.retrodev.com/repos/blastem/archive/v${PV}.tar.bz2 -> blastem-${PV}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND="
+ sys-libs/zlib
+ media-libs/libsdl2
+ media-libs/glew
+"
+
+src_compile() {
+ emake \
+ HOST_ZLIB=1 \
+ DATA_PATH=/usr/share/blastem \
+ CONFIG_PATH=/usr/share/blastem
+}
+
+src_install() {
+ dobin blastem
+
+ insinto /usr/share/blastem
+ doins -r shaders images default.cfg rom.db gamecontrollerdb.txt systems.cfg
+}