aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/blastem/Manifest1
-rw-r--r--games-emulation/blastem/blastem-0.6.2.ebuild39
-rw-r--r--games-emulation/blastem/blastem-9999.ebuild38
-rw-r--r--games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild42
-rw-r--r--games-emulation/simple64-core/simple64-core-9999.ebuild45
-rw-r--r--games-emulation/simple64-gui/files/fix-paths.patch43
-rw-r--r--games-emulation/simple64-gui/simple64-gui-9999.ebuild56
-rw-r--r--games-emulation/simple64-input-qt/simple64-input-qt-9999.ebuild42
-rw-r--r--games-emulation/simple64-input-raphnetraw/simple64-input-raphnetraw-9999.ebuild43
-rw-r--r--games-emulation/simple64-rsp-parallel/simple64-rsp-parallel-9999.ebuild42
-rw-r--r--games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild46
-rw-r--r--games-emulation/simple64/simple64-9999.ebuild20
12 files changed, 457 insertions, 0 deletions
diff --git a/games-emulation/blastem/Manifest b/games-emulation/blastem/Manifest
new file mode 100644
index 0000000..6add171
--- /dev/null
+++ b/games-emulation/blastem/Manifest
@@ -0,0 +1 @@
+DIST blastem-0.6.2.tar.bz2 1013238 BLAKE2B 5aa5ae867d5a6fb25fbb116fd698e59b4c2fdc9adffa50571e7449a43ed9ac77bc1fbdb3d1bbf132286ed30d34d41bbaff90905745b37789b483e647d871622c SHA512 fd924e5ec173f309e9e4108b78037ec78ed0f16d98e038a9a79f4e7237e30c1df4c7d65b166f65a26a20051e4c1d4b0c050bebd6f920e5e27ac467cb04e338e4
diff --git a/games-emulation/blastem/blastem-0.6.2.ebuild b/games-emulation/blastem/blastem-0.6.2.ebuild
new file mode 100644
index 0000000..5e4b4b5
--- /dev/null
+++ b/games-emulation/blastem/blastem-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Sega Genesis / Mega Drive emulator"
+HOMEPAGE="https://www.retrodev.com/blastem/"
+
+if [[ ${PV} == 9999 ]]; then
+ EHG_REPO_URI="https://www.retrodev.com/repos/blastem"
+ inherit mercurial
+else
+ SRC_URI="https://www.retrodev.com/repos/blastem/archive/v${PV}.tar.bz2 -> blastem-${PV}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86"
+ S="${WORKDIR}/blastem-v${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND="
+ sys-libs/zlib
+ media-libs/libsdl2
+ media-libs/glew
+"
+
+src_compile() {
+ emake \
+ HOST_ZLIB=1 \
+ DATA_PATH=/usr/share/blastem \
+ CONFIG_PATH=/usr/share/blastem
+}
+
+src_install() {
+ dobin blastem
+
+ insinto /usr/share/blastem
+ doins -r shaders images default.cfg rom.db gamecontrollerdb.txt systems.cfg
+}
diff --git a/games-emulation/blastem/blastem-9999.ebuild b/games-emulation/blastem/blastem-9999.ebuild
new file mode 100644
index 0000000..0b6f12c
--- /dev/null
+++ b/games-emulation/blastem/blastem-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Sega Genesis / Mega Drive emulator"
+HOMEPAGE="https://www.retrodev.com/blastem/"
+
+if [[ ${PV} == 9999 ]]; then
+ EHG_REPO_URI="https://www.retrodev.com/repos/blastem"
+ inherit mercurial
+else
+ SRC_URI="https://www.retrodev.com/repos/blastem/archive/v${PV}.tar.bz2 -> blastem-${PV}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND="
+ sys-libs/zlib
+ media-libs/libsdl2
+ media-libs/glew
+"
+
+src_compile() {
+ emake \
+ HOST_ZLIB=1 \
+ DATA_PATH=/usr/share/blastem \
+ CONFIG_PATH=/usr/share/blastem
+}
+
+src_install() {
+ dobin blastem
+
+ insinto /usr/share/blastem
+ doins -r shaders images default.cfg rom.db gamecontrollerdb.txt systems.cfg
+}
diff --git a/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild b/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild
new file mode 100644
index 0000000..3f2e8b6
--- /dev/null
+++ b/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, SDL2 audio plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/simple64-audio-sdl2.git"
+else
+ _git_commit="41aa2887f50fddd78e86ea624e1dc833de5fdc53"
+ SRC_URI="https://github.com/simple64/simple64-audio-sdl2/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+ media-libs/libsdl2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-audio-sdl2.so"
+}
diff --git a/games-emulation/simple64-core/simple64-core-9999.ebuild b/games-emulation/simple64-core/simple64-core-9999.ebuild
new file mode 100644
index 0000000..c96295c
--- /dev/null
+++ b/games-emulation/simple64-core/simple64-core-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, core library"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/mupen64plus-core.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="cd23b26262c7a4f94cb133926a9f818e144b5369"
+ SRC_URI="https://github.com/simple64/mupen64plus-core/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 Apache-2.0 BSD-2 LGPL-2.1+ ZLIB BitstreamVera"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/libsdl2
+ !!games-emulation/mupen64plus-core
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}/libmupen64plus.so"
+
+ insinto "/usr/share/mupen64plus"
+ doins -r "${S}"/data/*
+
+ insinto "/usr/include/mupen64plus"
+ doins "${S}"/src/api/m64p_*.h
+}
diff --git a/games-emulation/simple64-gui/files/fix-paths.patch b/games-emulation/simple64-gui/files/fix-paths.patch
new file mode 100644
index 0000000..e153eb6
--- /dev/null
+++ b/games-emulation/simple64-gui/files/fix-paths.patch
@@ -0,0 +1,43 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4f967af..bb8833b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,12 @@ endif()
+ include_directories(../mupen64plus-core/src/api)
+
+ add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x0602ff -DNETPLAY_VER=16)
++if(DEFINED PLUGIN_DIR_PATH)
++ add_definitions(-DPLUGIN_DIR_PATH="${PLUGIN_DIR_PATH}")
++endif()
++if(DEFINED CORE_LIBRARY_PATH)
++ add_definitions(-DCORE_LIBRARY_PATH="${CORE_LIBRARY_PATH}")
++endif()
+
+ if(DEFINED ENV{NETPLAY_AUTH_CODE})
+ add_definitions(-DNETPLAY_AUTH_CODE="$ENV{NETPLAY_AUTH_CODE}")
+diff --git a/cheats.cpp b/cheats.cpp
+index 84bac85..475b7a2 100644
+--- a/cheats.cpp
++++ b/cheats.cpp
+@@ -229,7 +229,7 @@ QString getCheatGameName()
+
+ QJsonObject loadCheatData(QString gameName)
+ {
+- QString cheats_path = QDir(QCoreApplication::applicationDirPath()).filePath("cheats.json");
++ QString cheats_path = QDir(QStringLiteral(u"/usr/share/mupen64plus")).filePath("cheats.json");
+ QFile file(cheats_path);
+ file.open(QIODevice::ReadOnly | QIODevice::Text);
+
+diff --git a/mainwindow.cpp b/mainwindow.cpp
+index 2d46d81..3c29dd3 100644
+--- a/mainwindow.cpp
++++ b/mainwindow.cpp
+@@ -353,7 +353,7 @@ void MainWindow::updateApp()
+
+ void MainWindow::setupDiscord()
+ {
+- QLibrary *discordLib = new QLibrary((QDir(QCoreApplication::applicationDirPath()).filePath("discord_game_sdk")), this);
++ QLibrary *discordLib = new QLibrary(QStringLiteral("discord_game_sdk"), this);
+
+ memset(&discord_app, 0, sizeof(discord_app));
+
diff --git a/games-emulation/simple64-gui/simple64-gui-9999.ebuild b/games-emulation/simple64-gui/simple64-gui-9999.ebuild
new file mode 100644
index 0000000..c18d794
--- /dev/null
+++ b/games-emulation/simple64-gui/simple64-gui-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, GUI frontend"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/mupen64plus-gui.git"
+else
+ _git_commit="5e2995912bf712deac247b1cd7d768f6d7f0ceb3"
+ SRC_URI="https://github.com/simple64/mupen64plus-gui/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 Apache-2.0 BSD-2 LGPL-2.1+ ZLIB BitstreamVera"
+SLOT="0/${PV}"
+IUSE="discord"
+
+DEPEND="
+ games-emulation/simple64-core:=
+ dev-qt/qtbase:6=[widgets]
+ dev-qt/qtwebsockets:6=
+ discord? ( dev-libs/discord-game-sdk )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/fix-paths.patch"
+)
+
+src_prepare() {
+ local commit="${_git_commit}"
+ if [[ ${PV} == 9999 ]]; then
+ commit="$(git rev-parse HEAD)"
+ fi
+ echo "#define GUI_VERSION \"${_git_commit}\"" >version.h
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCORE_LIBRARY_PATH="/usr/$(get_libdir)"
+ -DPLUGIN_DIR_PATH="/usr/$(get_libdir)/mupen64plus"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/simple64-gui"
+}
diff --git a/games-emulation/simple64-input-qt/simple64-input-qt-9999.ebuild b/games-emulation/simple64-input-qt/simple64-input-qt-9999.ebuild
new file mode 100644
index 0000000..ebcc5e4
--- /dev/null
+++ b/games-emulation/simple64-input-qt/simple64-input-qt-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, Qt input plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/simple64-input-qt.git"
+else
+ _git_commit="0e64669899410c6ceb183acb3ef94920dc028180"
+ SRC_URI="https://github.com/simple64/simple64-input-qt/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+ dev-qt/qtbase:6=[network,widgets]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-input-qt.so"
+}
diff --git a/games-emulation/simple64-input-raphnetraw/simple64-input-raphnetraw-9999.ebuild b/games-emulation/simple64-input-raphnetraw/simple64-input-raphnetraw-9999.ebuild
new file mode 100644
index 0000000..66990e9
--- /dev/null
+++ b/games-emulation/simple64-input-raphnetraw/simple64-input-raphnetraw-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, raphnetraw input plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/simple64-input-raphnetraw.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="0e64669899410c6ceb183acb3ef94920dc028180"
+ SRC_URI="https://github.com/simple64/simple64-input-raphnetraw/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ sed -i 's|#include "config.h"|#include "m64p_config.h"|' src/plugin_front.c
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-input-raphnetraw.so"
+}
diff --git a/games-emulation/simple64-rsp-parallel/simple64-rsp-parallel-9999.ebuild b/games-emulation/simple64-rsp-parallel/simple64-rsp-parallel-9999.ebuild
new file mode 100644
index 0000000..7b5514b
--- /dev/null
+++ b/games-emulation/simple64-rsp-parallel/simple64-rsp-parallel-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, paraLLEl RSP plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/parallel-rsp.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="a6db2c75bd60a62a8abfe1b4e767fd014ba380e5"
+ SRC_URI="https://github.com/simple64/parallel-rsp/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-rsp-parallel.so"
+}
diff --git a/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild b/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild
new file mode 100644
index 0000000..1ecb651
--- /dev/null
+++ b/games-emulation/simple64-video-parallel/simple64-video-parallel-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, paraLLEl-RDP video plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/parallel-rdp-standalone.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="420e12f677b5d4f6a624442e20594f181e451760"
+ SRC_URI="https://github.com/simple64/parallel-rdp-standalone/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+ dev-util/vulkan-headers
+"
+RDEPEND="
+ ${DEPEND}
+ media-libs/vulkan-loader
+"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-video-parallel.so"
+}
diff --git a/games-emulation/simple64/simple64-9999.ebuild b/games-emulation/simple64/simple64-9999.ebuild
new file mode 100644
index 0000000..18d64ca
--- /dev/null
+++ b/games-emulation/simple64/simple64-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, meta-package"
+HOMEPAGE="https://simple64.github.io/"
+
+LICENSE="metapackage"
+SLOT="0/${PV}"
+
+RDEPEND="
+ games-emulation/simple64-core:=
+ games-emulation/simple64-input-raphnetraw:=
+ games-emulation/simple64-input-qt:=
+ games-emulation/simple64-audio-sdl2:=
+ games-emulation/simple64-gui:=
+ games-emulation/simple64-rsp-parallel:=
+ games-emulation/simple64-video-parallel:=
+"