aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild')
-rw-r--r--games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild b/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild
new file mode 100644
index 0000000..3f2e8b6
--- /dev/null
+++ b/games-emulation/simple64-audio-sdl2/simple64-audio-sdl2-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, SDL2 audio plugin"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/simple64-audio-sdl2.git"
+else
+ _git_commit="41aa2887f50fddd78e86ea624e1dc833de5fdc53"
+ SRC_URI="https://github.com/simple64/simple64-audio-sdl2/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ games-emulation/simple64-core:=
+ media-libs/libsdl2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's|include_directories(../mupen64plus-core/src/api)|include_directories(/usr/include/mupen64plus)|' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/mupen64plus"
+ doins "${BUILD_DIR}/simple64-audio-sdl2.so"
+}