aboutsummaryrefslogtreecommitdiffstats
path: root/games-emulation/simple64-core
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/simple64-core')
-rw-r--r--games-emulation/simple64-core/simple64-core-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-emulation/simple64-core/simple64-core-9999.ebuild b/games-emulation/simple64-core/simple64-core-9999.ebuild
new file mode 100644
index 0000000..c96295c
--- /dev/null
+++ b/games-emulation/simple64-core/simple64-core-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Accurate Nintendo 64 Emulator, core library"
+HOMEPAGE="https://simple64.github.io/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/simple64/mupen64plus-core.git"
+ EGIT_BRANCH="simple64"
+else
+ _git_commit="cd23b26262c7a4f94cb133926a9f818e144b5369"
+ SRC_URI="https://github.com/simple64/mupen64plus-core/archive/${_git_commit}.tar.gz -> ${PN}-${_git_commit}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 Apache-2.0 BSD-2 LGPL-2.1+ ZLIB BitstreamVera"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/libsdl2
+ !!games-emulation/mupen64plus-core
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}/libmupen64plus.so"
+
+ insinto "/usr/share/mupen64plus"
+ doins -r "${S}"/data/*
+
+ insinto "/usr/include/mupen64plus"
+ doins "${S}"/src/api/m64p_*.h
+}